Opened 11 years ago

Closed 11 years ago

#9 closed task (fixed)

Backwards compatibility with Python < 2.5 and PyGTK < 2.10

Reported by: Ingmar Steen Owned by: Ingmar Steen
Priority: blocker Milestone: 0.9.0
Component: multiple Version: trunk
Keywords: Cc:

Description

Make sure MethLab works with at least Python 2.4 (and if feasible, Python 2.2). Also check which user interface features depend on PyGTK 2.10 and disable those when an earlier version of PyGTK is detected.

Change History (8)

comment:1 Changed 11 years ago by Ingmar Steen

Summary: Backwards compatibilityBackwards compatibility with Python < 2.5 and PyGTK < 2.10

comment:2 Changed 11 years ago by Ingmar Steen

Component: unspecifiedmultiple

comment:3 Changed 11 years ago by Ingmar Steen

Things identified so far that are not available in PyGTK < 2.10:

  • gtk.StatusIcon
  • show-expanders and level-indentation properties (used for artists not-collapsible)

comment:4 Changed 11 years ago by Ingmar Steen

(In [71]) Check PyGTK 2.10 at startup. Require 2.10 for now. (Refs: #9)

comment:5 Changed 11 years ago by Ingmar Steen

(In [78]) Check for gtk.StatusIcon? presence at runtime (Refs: #9).

comment:6 Changed 11 years ago by Ingmar Steen

(In [79]) Check for level-indentation and show-expanders on runtime (Refs: #9)

comment:7 Changed 11 years ago by Ingmar Steen

(In [82]) Handle broken track number tags better. Properly trap exceptions when scanning tags. Python 2.4 compatibility fix (Refs: #9).

comment:8 Changed 11 years ago by Ingmar Steen

Resolution: fixed
Status: newclosed

(In [83]) Lower PyGTK dependency to 2.8. Check for Python >= 2.4. (Closes: #9)

Note: See TracTickets for help on using tickets.